Jump to content

Sign in to follow this  
Spangles72

1999 CRV - how many lambda sensors does it have??

Recommended Posts

Hi all, 

 

I had the cat stolen from my 1999 CRV and I've replaced the cat and various exhaust parts to get it going again, but now its reving high on idle, and after a couple of minutes the engine management light comes on.  Now when I was replacing the exhaust I could only find one block connector coming from the wiring loom for a lambda sensor, but shouldn't  it should have 2, and this might be why I have the problem?? The one I found was behind the engine block..... does anyone know if there should be 2, and is so where on earth does it go???  Thanks... pulling out what little hair I have left here!!

Share this post


Link to post
Share on other sites
 

Hi....welcome to the Forum

 

On a 1999 car there would probably only be the one oxygen sensor, but being as it's Japanese origin then it may actually have two sensors fitted.

The easiest way to determine this would be to scan the Engine Management for fault codes and if it has downstream or number 2 oxygen sensor listed as a fault then you will need to locate the second lead to connect up another sensor.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...