Jump to content

Sign in to follow this  
Bon Scott

PGM-FI relay location

Recommended Posts

Hello does anybody know where the PGM FI relay is ? Iv got a 2005 1.7 FR V that iv just replaced the head gasket and all the belts on. It worked fine for 20 miles or so, making various stops for shopping and then on the motorway it just cut out and wont start at all. Theres spark from the plugs and fuel is pumping to the injector rail but they're not firing. apparently the PGM FI relay is a common fault on Hondas and when they fail either the fuel pump stops working or the injectors. The pump is pumping. So i just need to find it and test it or swap it with the one in my other FRV which the clutch has gone on. Iv looked on both fuse boards plus looked behind the glove box and checked there. Whilst there i reset the fuel cut off switch but still no ignition. Any ideas ?

Share this post


Link to post
Share on other sites
 

Hi....welcome to the Forum

 

If it is sparking and there is fuel being supplied from the pump then it does not sound like a system relay or crank sensor at fault.

I would be tempted to run a compression test and check all the belts just in case one has moved a tooth, etc

Let us know what you find

Share this post


Link to post
Share on other sites

Compression is fine. Im a mechanic and have done every test there is. The PGMFI relay controls the fuel pump and the injectors. Iv uplugged the fuel line to the injector rail and as soon as i turn the key it pumps fuel out of the hose so the pump is fine but something is stopping the injectors. They're not clogged iv swapped them with ones off of our other FRV which i even started up first so i knew they worked. The green flashing key signal doesn't stay on so its not a key coding issue. Im sick to death of it now.

It ran fine before but was over heating due to the gasket. Then ran beautiful after id replacef the gasket and belts until it suddenly cut out while driving. The cam belt hasn't moved either and i have run out of ideas. Plus its stuck outside my house so i cant even get it to work. I want to set fire to ******* thing

Share this post


Link to post
Share on other sites

I think you'll find that the PGMFI system relay will run the pump and other subsystems but it will still rely on a crank sensor signal to trigger the injectors.
If no signal then the system will not know the engine is turning and also the frequency of pulses relating to engine rpm.

Worth looking at any connections and wiring to the Crankshaft (and Camshaft) sensor just in case they have been swapped over accidentally or not connecting properly

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...