Jump to content

Recommended Posts

Hi folks im currently having issues with my drivers side wiper its not wiping correctly at around the middle its leaving streaks of rain and its making it difficult to see. Its been like this since i bought the car. i changed the wipers because i thought that this was what the issue was. the issue continued. i noticed a small chip in the glass and around where the wipers where not wiping correctly there where small scratches on the glass. the windshield has since been replaced and the issue still persists. i am at my wits end with it as i dont know what the issue could be. any ideas ??

Share this post


Link to post
Share on other sites
 

I would imagine it is the wiper arm (not the blade) that is at fault as this part provides downwards pressure against the screen.

Maybe worth trying a new one of these, probably dealer only though

 

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, Trevor said:

I would imagine it is the wiper arm (not the blade) that is at fault as this part provides downwards pressure against the screen.

Maybe worth trying a new one of these, probably dealer only though

 

I gave the wiper blade a good clean and lubricated the spring mechanism and this seems to have solved the issue so i will be keeping a close eye on it. Thank you for your reply my friend. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...