Jump to content

Recommended Posts

just noticed both the heated seats are not working checked the fuse that is ok seems rather strange both are not working, anyone any ideas on this ? not checked the relays but would be rather odd that all four relays have given up the ghost.

Link to post
Share on other sites


That is odd, has to be a common connection, such as power feed or earth....worth starting at the switch(s) and working back from there until you find power feed

Also, is there a link between the heated rear screen or heated mirrors, do these work as they should?

  • Like 1
Link to post
Share on other sites

not checked rear screen or heated mirrors as yet i can understand one relay packing up but not all four i'll have a play and and see what i can find.

  • Like 1
Link to post
Share on other sites

checked heated rear window fuse under bonnet thats  ok and tried to get the relays out from under drivers seat, and what a game that is even with seat in its highest position with the relay loom uncliped holding the plastic clips in just cannot shift the relays think i may unbolt the seat and tip it back so i can get more room to shift the wretched things, its possible they are frozen in the sockets.

Link to post
Share on other sites

It could be water ingress that's seized them in place?
Could also explain them all failing at the same time (if that is the case)

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...